Login and authentication issue
Incident Report for Boundless
Resolved
This incident has been resolved.
Posted Apr 08, 2024 - 12:42 PDT
Investigating
We're currently investigating login issues. We will provide another update shortly.
Posted Apr 08, 2024 - 11:30 PDT
This incident affected: Boundless Servers.